请教下 安装event扩展的问题

0

我的环境是alpine 3.6,php7.1.5


安装过程


apk add libevent-dev
pecl install event
echo extension=event.so > /etc/php7/conf.d/event.ini
pecl clear-cache

php -m | grep event
PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php7/modules/event.so' - Error relocating /usr/lib/php7/modules/event.so: bufferevent_openssl_get_allow_dirty_shutdown: symbol not found in Unknown on line 0

ps之前php create socket报错解决了,安装了php7-sockets扩展后解决。现在出现了新的问题

已邀请:

ayamzh

赞同来自:

这是我安装的步骤~~


#安装nginx supervisor 等软件
apk add --update nginx openssh supervisor git curl curl-dev make zlib-dev build-base zsh vim

#安装PHP
apk --update add php7 php7-dev php7-mysqlnd php7-pdo_mysql php7-mysqli php7-mcrypt php7-mbstring php7-openssl php7-json php7-redis php7-mysqli php7-gd php7-fpm php7-bcmath php7-tokenizer php7-gettext php7-iconv php7-curl php7-pear php7-phar php7-memcached php7-opcache

#安装mongodb扩展
apk add openssl-dev
pecl install mongodb
echo extension=mongodb.so > /etc/php7/conf.d/mongodb.ini
pecl clear-cache

#安装kafka扩展
apk add libssl1.0
apk add librdkafka-dev
pecl install rdkafka
echo extension=rdkafka.so > /etc/php7/conf.d/rdkafka.ini
pecl clear-cache

#安装couchbase扩展
apk del openssl-dev 必须删除 和libcouchbase-dev冲突
apk add libcouchbase-dev
pecl install couchbase-2.2.3
echo extension=couchbase.so > /etc/php7/conf.d/couchbase.ini
pecl clear-cache

#安装event扩展?
apk add libevent-dev
pecl install event
echo extension=event.so > /etc/php7/conf.d/event.ini
pecl clear-cache

ayamzh

赞同来自:

求老大指点

walkor

赞同来自:

没遇到过,不清楚

要回复问题请先登录注册