wss 问题, wrong version number


QQ图片20190122143546.png

请大佬帮忙看下什么问题, 刚开始学习workman, 微信小程序接入websocket,服务端报错。
参照着这个链接去写的:http://doc.workerman.net/315297
已邀请:

six

赞同来自:

看起来是什么协议版本问题。不行用nginx或者apache代理SSL那个方法呗

blogdaren - 喜欢分享的PHP码农【http://www.blogdaren.com】

赞同来自:

1. nginx 代理能很好的解决这个问题,nginx 支持SSLv3;
2. 不过这个问题的原因应该是:客户端使用了SSLv3协议所致,但是workerman 层面已经禁用了SSLv3协议,所以报题示错误。
3. 正好今天我刚在github提了个相关的issue,里面也能获知为什么要禁用SSLv3协议,可以参考下:
https://github.com/walkor/Workerman/issues/399

要回复问题请先登录注册