无法composer require 异步http-client组件,composer报错,我升级了版本

0
composer require workerman/http-client

执行这一步时报错,初步怀疑是workerman版本原因,原有版本是3.5.16


升级版本到3.5.23,再次执行,还是一样的错误
有没有大佬帮忙看一下什么原因
php版本是7.2
下面是错误信息


Your requirements could not be resolved to an installable set of packages.

Problem 1
- Installation request for workerman/http-client dev-master -> satisfiable by workerman/http-client[dev-master].
- Conclusion: remove workerman/workerman dev-master
- workerman/http-client dev-master requires workerman/workerman 3.* -> satisfiable by workerman/workerman[v3.1.1, v3.1.2, v3.1.3, v3.1.4, v3.1.5, v3.1.6, v3.1.7, v3.1.8, v3.1.9, v3.2.0, v3.2.2, v3.2.5, v3.2.6, v3.2.7, v3.2.8, v3.2.9, v3.3.0, v3.3.1, v3.3.3, v3.3.4, v3.3.5, v3.3.6, v3.3.7, v3.3.8, v3.3.9, v3.4.0, v3.4.1, v3.4.2, v3.4.3, v3.4.4, v3.4.5, v3.4.6, v3.4.7, v3.5.0, v3.5.1, v3.5.10, v3.5.11, v3.5.12, v3.5.13, v3.5.14, v3.5.15, v3.5.16, v3.5.17, v3.5.18, v3.5.19, v3.5.2, v3.5.20, v3.5.21, v3.5.22, v3.5.3, v3.5.4, v3.5.5, v3.5.6, v3.5.7, v3.5.8, v3.5.9].
- Can only install one of: workerman/workerman[v3.1.1, dev-master].
/···
- Can only install one of: workerman/workerman[v3.5.9, dev-master].
- Installation request for workerman/workerman dev-master -> satisfiable by workerman/workerman[dev-master].

Installation failed, reverting ./composer.json to its original content.
已邀请:

要回复问题请先登录注册