在GatewayWorker中使用mysql时提示不存在PDO类,大家有碰到吗?怎么处理?谢谢

已邀请:

3144428576

赞同来自:

我也遇到这个问题,apache测试正常,但是workermanchat里面就不行,

3144428576

赞同来自:

我想知道,workerman是怎么 加载php的

3144428576

赞同来自:

谁知道这个问题那,php -m 扩展都有了 说是命名空间什么问题那

walkor

赞同来自:

根据手册去安装
http://doc3.workerman.net/appendices/install-extension.html

需要安装 pdo和pdo_mysql两个扩展

marssu - 80后IT男

赞同来自:

正如群主所说,用yum安装完两个扩展就好了。我是从web转过来的,所以一直有个错误的观点,认为web下pdo没问题应该就不是pdo的问题,在workerman里边,项目是以cli形式运行,所以有所不同,如果有相同问题的人可以用php --ini看看是否已经装好pdo扩展

要回复问题请先登录注册