workerman需要的php模块posix、pcntl、sysvshm、sysvmsg缺少,怎么办

请问怎么安装php模块posix、pcntl、sysvshm、sysvmsg

已邀请:

phpgame

赞同来自:

如果您的php是源码编译,那么请进到php的源码目录,再进入ext目录下,分别找到相应的php模块目录,进行编译
  1. 假设php目录为/usr/local/php, 进到相应的php模块目录,执行
<pre>/usr/local/php/bin/phpize</pre>
  1. 接着执行
<pre>./configure –with-php-config=/usr/local/php/bin/php-config</pre>
  1. 接着执行以下命令
<pre>make && make install </pre>
如果没权限,那么执行以下命令
<pre>sudo make && sudo make install </pre>
  1. 编译完成后,会显示so在哪个目录下,然后打开php.ini之后,在相应地方加入
<pre> extension=xx.so </pre>

另外一种安装的方法
centos
1、命令行运行yum install php-cli php-process git php-devel php-pear libevent-devel
2、命令行运行pecl install channel://pecl.php.net/libevent-0.1.0
3、命令行运行echo extension=libevent.so > /etc/php.d/libevent.ini

debian/ubuntu
1、命令行运行apt-get update && apt-get install php5-cli git php-pear php5-dev libevent-dev
2、命令行运行pecl install channel://pecl.php.net/libevent-0.1.0
3、命令行运行echo extension=libevent.so > /etc/php5/cli/conf.d/libevent.ini

要回复问题请先登录注册