webman安装数据库后无法启动

0

composer require illuminate/database
执行上面安装数据库后无法启动

已邀请:

walkor

赞同来自:

刚测试了,没有出现你说的问题。


git clone --depth=1 https://github.com/walkor/webman
cd webman
composer install
composer require illuminate/database
// 编辑app/controller/Index.php 加入数据库逻辑
php start.php start

访问正常。

wadeYang - 老菜鸟

赞同来自:

我重新按你搞一次,只要安装数据库,还是不行。有windows下面遇到相同的问题的吗?


报错w文件 D:\www\webman\vendor\illuminate\support\Env.php:69 行
我进去编辑器跟踪上面use类,确实没有发现文件。
命名空间:Dotenv 是在vlucas里面的,如上图,确实没有

wadeYang - 老菜鸟

赞同来自:

试了下,linux下面没有问题
发现Env.php文件不同

wadeYang - 老菜鸟

赞同来自:

找到问题了,是composer版本的问题,装的 composer require illuminate/database
是6版本

要回复问题请先登录注册