workerman/redis 语法不兼容 PHP7.4

0

使用 PHP7.4 运行 workerman/redis-queue ,当队列中没有数据时报错。使用 PHP7.3 没有报错


截图


截图


截图


截图

已邀请:

blogdaren - 常年游走于 Linux、PHP、C、VIM 之间【http://www.phpcreeper.com】

赞同来自:

1、workerman是基于纯PHP开发的,也完全遵循PHP的语法,所以不是workerman的问题,就如你标题所言,语法层面是否兼容是PHP版本之间的差异。
2、另外程序本身要对接收到的一切外部数据进行必要的校验,不要直接起飞。

walkor

赞同来自:

已经修复,请更新 workerman/redis 到1.0.3或者后续的更高版本。

要回复问题请先登录注册