记一次关于php8.0安装event问题

0

由于项目使用composer要求php必须为php8,在安装event过程中一直安装失败,中途各种报错都有,后来才发现好像是低版本的event不支持php8.0,后来使用最新版本3.0.5成功安装
yum install libevent -y
wget https://pecl.php.net/get/event-3.0.5.tgz
tar -zxvf event-3.0.5.tgz
cd event-3.0.5
/www/server/php/80/bin/phpize
./configure --with-php-config=/www/server/php/80/bin/php-config
make && make install
echo "extension=event.so" >> /www/server/php/80/etc/php.ini
service php-fpm-80 reload
截图
看到这个页面就很开心

已邀请:

nitron

赞同来自:

用PECL安装

zhanbai

赞同来自:

哈哈,我也是 PHP8 遇到了这个问题,用源码编译安装了高版本。

黑老怪

赞同来自:

刚需 正好用上 感谢分享!

dignfei - 丹妮

赞同来自:

你安装event后遇到这个问题了吗? https://wenda.workerman.net/question/6717

yitao

赞同来自:

不好意思,我这边没遇到过啊

要回复问题请先登录注册