我想配置一个linux自动开启容器的脚本,但是webman的容器一直报错找不到环境变量,这是为什么呢

0

我的脚本是这样的截图
这行命令的报错是这样的截图
我的yml文件是这样的截图
应该是没读到.env文件,但是我在webman的dockerfile中没看到哪里有读了.env文件,来个大佬救救我吧

已邀请:

zombie

赞同来自:

难顶

zombie

赞同来自:

没有大佬吗

WilliamA

赞同来自:

其实这个 docker 启动配置并不是 walkor 写的。https://github.com/yasarluo/webman-dock 这里写明了需要cp env-example .env的,还要将里面的 HOST_APP_DIR 变量改成你自己的项目目录。


这个启动配置并不会帮你自动启动 webman,你还要自己进去启动,所以不是太好用。

weed

赞同来自:

# docker-compose --help 可以查看帮助说明
#
# 我这的版本是 docker-compose version 1.27.4
#
# Options:
# -f, --file FILE Specify an alternate compose file
# ...
# --env-file PATH Specify an alternate environment file
#
/usr/local/bin/docker-compose -f /project/docker-compose.yml --env-file /project/.env up -d

要回复问题请先登录注册